Aegis X battery pirate!

Discussion in 'Help My Vape Broke!' started by Munro31, 4/1/22.

  1. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    Hi guys, I have A Aegis X dual battery mod, it seems to have a battery drain on one battery much more than the other, it never did this before but started about a week ago. I have changed the settings on the ABB from on to off and back on and it makes no difference, even though it's suppose to balance it, any suggestions?
     
  2. Raindance

    Excellent Member

    5/5, 8 votes

    Raindance Vaping Addict ECIGSSA Donor

    Threads:
    55
    Posts:
    4,588
    Country:
    South Africa
    Joined:
    26/8/16
    Gender:
    Male
    Location:
    Brackenfell, Cape Town
    Ratings:
    +16,275
    You will notice when you open the battery compartment that there is a contact point of sorts reading the charge in the first cell. Clean both this point and its contact area and you should be good to go for another period until it needs cleaning again.

    Regards
     
    • Informative Informative x 4
    • Agree Agree x 2
    • Like Like x 1
    • Thanks Thanks x 1
    • List
  3. Grand Guru

    Excellent Member

    5/5, 9 votes

    Grand Guru The Vape Guru ECIGSSA Donor

    Threads:
    46
    Posts:
    6,255
    Country:
    South Africa
    Joined:
    25/9/18
    Gender:
    Male
    Location:
    Bloemfontein
    Ratings:
    +43,146
    The problem may be that one of the batteries is close to dying. You should try another set of batteries in the Aegis and try the same set in another mod…
     
    • Thanks Thanks x 1
    • Agree Agree x 1
    • Informative Informative x 1
    • Can relate Can relate x 1
    • List
  4. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    Done that @Raindance , still does the same, contacts are shining I cleaned them so much!
     
    • Funny Funny x 2
    • Like Like x 1
    • List
  5. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    @Grand Guru , I have 6 paired sets, it does it with all of them, I also swopped the batteries to check if the battery problem followed the battery but it started drain the battery I swopped, so its definitely a problem in that battery bay
     
    • Informative Informative x 3
    • List
  6. Intuthu Kagesi

    Excellent Member

    5/5, 2 votes

    Intuthu Kagesi Ignoring dimwits-d & Karen

    Threads:
    27
    Posts:
    2,100
    Country:
    Unknown
    Joined:
    17/8/20
    Gender:
    Male
    Location:
    Bedfordview
    Ratings:
    +10,160
    Mark the cell that is draining more and swop their positions in the mod, (my guess is that it's one cell, not one slot on your mod that has passed its "sell by" date)
    Your mod has two cells in series, with balanced charging, not discharging ... Cells do age at different rates and getting two with identical internal resistances that age at the same rate is about as probable as the finding the element Unobtanium
     
    • Like Like x 1
    • Thanks Thanks x 1
    • Informative Informative x 1
    • List
  7. Raindance

    Excellent Member

    5/5, 8 votes

    Raindance Vaping Addict ECIGSSA Donor

    Threads:
    55
    Posts:
    4,588
    Country:
    South Africa
    Joined:
    26/8/16
    Gender:
    Male
    Location:
    Brackenfell, Cape Town
    Ratings:
    +16,275
    True, when using dual cell mods, keeping mated pairs, never using each without the other is important. Just replaced my old cells with five pairs of newly mated cells and notice their discharge level is equal every time I place them in the D2 charger. The Geekvape whatever it is I use as a daily driver does however discriminate against the second cell but I gave up worrying about it. I press the button, vape comes out, I'm happy. Really could not be bothered with what the screen is telling me.

    Regards
     
  8. Intuthu Kagesi

    Excellent Member

    5/5, 2 votes

    Intuthu Kagesi Ignoring dimwits-d & Karen

    Threads:
    27
    Posts:
    2,100
    Country:
    Unknown
    Joined:
    17/8/20
    Gender:
    Male
    Location:
    Bedfordview
    Ratings:
    +10,160
    It could be, (unlikely tho'), be the mods charge balancing circuitry at fault, drawing too much current from one cell?
    Or ...
    Your mod is simply reporting a false charge state on one of the cells, (my earlier suggestion of swopping them around should expose that tho'), and that there's nothing wrong with them.
     
    • Informative Informative x 3
    • Like Like x 1
    • Agree Agree x 1
    • List
    Last edited: 4/1/22
  9. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    Done that, it keeps discharging whatever battery you put in that bay, it's a head scratcher!!
     
  10. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    It's not a little different, it's completely drained and won't vape within a hour, and that's with little vaping! I stopped using the mod because it's going to over discharge that one battery passed the point of no return
     
    • Like Like x 2
    • Informative Informative x 1
    • List
  11. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    There is definitely a problem internally, I'll see when I have time to strip it and check what's up. One battery will be one bar from full and the other completely discharged and the mod gives low battery warning and won't fire. If I take them out and put in my D4 it's reflects what the mod shows, one battery flat, the other almost fully charged. Will strip it sometime and see what the hell is going on!
     
    • Like Like x 2
    • Agree Agree x 1
    • List
  12. Intuthu Kagesi

    Excellent Member

    5/5, 2 votes

    Intuthu Kagesi Ignoring dimwits-d & Karen

    Threads:
    27
    Posts:
    2,100
    Country:
    Unknown
    Joined:
    17/8/20
    Gender:
    Male
    Location:
    Bedfordview
    Ratings:
    +10,160
    Then it is probably the most unlikely part ... the charge balancing circuitry that's faulty, and removing that thin wire that is attached to the bridge between the two batteries might be a temporary solution? albeit that your charge circuitry will no longer work, nor would individual cell status function.

    Cell charge balancing works very crudely, by discharging the stronger cell to match the weaker one(s).
     
    • Informative Informative x 3
    • List
  13. Intuthu Kagesi

    Excellent Member

    5/5, 2 votes

    Intuthu Kagesi Ignoring dimwits-d & Karen

    Threads:
    27
    Posts:
    2,100
    Country:
    Unknown
    Joined:
    17/8/20
    Gender:
    Male
    Location:
    Bedfordview
    Ratings:
    +10,160
     
    • Like Like x 3
    • Thanks Thanks x 1
    • List
  14. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    I'll have to gut the bastard and see what's cooking
     
  15. Intuthu Kagesi

    Excellent Member

    5/5, 2 votes

    Intuthu Kagesi Ignoring dimwits-d & Karen

    Threads:
    27
    Posts:
    2,100
    Country:
    Unknown
    Joined:
    17/8/20
    Gender:
    Male
    Location:
    Bedfordview
    Ratings:
    +10,160
    Take pics please ;)
     
  16. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    Autopsy must be documented, it's the law!
     
    • Funny Funny x 2
    • Agree Agree x 1
    • Winner Winner x 1
    • List
  17. Viper_SA

    Excellent Member

    5/5, 1 vote

    Viper_SA Vape on Wayne, Vape on Garth ECIGSSA Donor

    Threads:
    238
    Posts:
    4,267
    Country:
    South Africa
    Joined:
    19/2/15
    Gender:
    Male
    Location:
    Sasolburg
    Ratings:
    +10,253
    Looks and sounds to me like the perfect excuse for a new mod

    :couch:
     
  18. Munro31

    Not Rated Member

    0/5,

    Munro31 Vaping Enthusiast

    Threads:
    15
    Posts:
    859
    Country:
    South Africa
    Joined:
    19/8/20
    Gender:
    Male
    Location:
    Witbank
    Ratings:
    +3,444
    I'm thinking the same thing
     
    • Funny Funny x 2
    • Agree Agree x 1
    • List