Dead Siren 22mm

Discussion in 'Ask Vape Veteran' started by Spongebob, 1/6/19.

  1. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Need some help from the technical minded vapers recently traded a Siren 22mm from someone (brand new) that somehow came DOA? Worked 5 minutes and then started with the dreaded "no atomizer" on all my mods? Tinkered around but could not find anything? Tried someone else's advice and used thicker wire and swapped the grub screws and it worked for a day and a half and then started acting up again and has now passed on

    I have checked 510 screw, coil seating, grub screws, everything i can think off, but no luck even had a multi meter on it, but could not find anything even tried running coil wire directly from one grub screw to the other, but nada



    Is there anything anybody else can think of that i can check., because in all my years of vaping, the siren 22 is the best vape i have ever hadand if at all possible i would REALLY like to get her back to life?

    Sent from my LYA-L09 using Tapatalk
     
  2. Paul33

    Excellent Member

    5/5, 4 votes

    Paul33 Flavour chaser ECIGSSA Donor

    Threads:
    97
    Posts:
    3,056
    Country:
    South Africa
    Joined:
    6/12/16
    Gender:
    Male
    Location:
    Durban
    Ratings:
    +8,516
    I’ve had a similar issue in a rda once and it ended up being a tiny tiny piece of wire offcut that was causing a short. I had to take it all apart and wash and rinse and that solved the problem.

    I hope you come right. Nothing more irritating.
     
  3. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    I've taken it apart as far as I could the deck on the siren doesn't come out so can't check there

    Sent from my LYA-L09 using Tapatalk
     
  4. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    With the coil on, the multimeter said open circuit or short ?


    Sent from my SM-A730F using Tapatalk
     
  5. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    I wouldn't know about that but there was no reading

    Sent from my LYA-L09 using Tapatalk
     
  6. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    How do i check that btwconnect meter and fire the mod

    Sent from my LYA-L09 using Tapatalk
     
  7. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Whoops just remembered the siren does not fire

    Sent from my LYA-L09 using Tapatalk
     
  8. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Riddle me this there is no continuity between the areas marked with arrows when tested so how did it fire in the first place

    Sent from my LYA-L09 using Tapatalk
     
  9. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Whoops pic attached

    [​IMG]

    Sent from my LYA-L09 using Tapatalk
     
  10. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    This is the position of the knob on the multimeter u need to use for checking continuity [​IMG]

    Sent from my SM-A730F using Tapatalk
     
    • Like Like x 1
    • Winner Winner x 1
    • List
  11. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    Now to test the rta, use the probes and touch it on the 510 connectors, like this. Notice the reading, this reading means there is continuity [​IMG]

    Sent from my SM-A730F using Tapatalk
     
    • Like Like x 1
    • Winner Winner x 1
    • List
  12. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    Check and let me know, I will then guide u further.

    Sent from my SM-A730F using Tapatalk
     
    • Winner Winner x 3
    • Like Like x 1
    • List
  13. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    That is what i didand almost everywhere i touched it beeped except between the two points with the arrows

    Sent from my LYA-L09 using Tapatalk
     
  14. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    So I guessing u took out the positive pin(the screw) and the positive post, then u touched the probe on the 510 thread(the negative terminal) and the post, and u got no beep on the continuity tester. Is that right?

    Sent from my SM-A730F using Tapatalk
     
    Last edited: 2/6/19
  15. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Yes exactly like that

    Sent from my LYA-L09 using Tapatalk
     
  16. Resistance

    Excellent Member

    5/5, 3 votes

    Resistance Vaping Addict

    Threads:
    21
    Posts:
    3,289
    Country:
    South Africa
    Joined:
    15/12/17
    Location:
    Cape
    Ratings:
    +10,071
    If you put the positive pin back in the atty, do you get a reading on the pin+ and the post+?
    And then also on the post+and the post -.
     
  17. Resistance

    Excellent Member

    5/5, 3 votes

    Resistance Vaping Addict

    Threads:
    21
    Posts:
    3,289
    Country:
    South Africa
    Joined:
    15/12/17
    Location:
    Cape
    Ratings:
    +10,071
    Also on the pin +and pin -?
     
  18. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    ExplainI'm a banker not a techy

    Sent from my LYA-L09 using Tapatalk
     
  19. Resistance

    Excellent Member

    5/5, 3 votes

    Resistance Vaping Addict

    Threads:
    21
    Posts:
    3,289
    Country:
    South Africa
    Joined:
    15/12/17
    Location:
    Cape
    Ratings:
    +10,071
    I have an atty that when its complete ,it does the same thing.its a kylin v1.
    When I install a coil I get the error code no atty.
    as soon as I undo the grub screws it starts reading the coil.
    My question is. When your atty is completely assembled.do you get a reading from the positive pin to the positive post, and the same on the negative pin to the negative post.

    Then also with the complete atty does it read between the two posts and pins respectively?
    Trying to analize the actual cause
     
  20. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    If i am understanding you correctly positive pin to post yes, negative to post no?

    Sent from my LYA-L09 using Tapatalk
     
  21. Resistance

    Excellent Member

    5/5, 3 votes

    Resistance Vaping Addict

    Threads:
    21
    Posts:
    3,289
    Country:
    South Africa
    Joined:
    15/12/17
    Location:
    Cape
    Ratings:
    +10,071
    Ok rub a magnet on the atty sub assembly prefferably inside a cloth to avoid scratches.reasemble and check again on a mod
     
  22. Faiyaz Cheulkar

    Excellent Member

    5/5, 2 votes

    Faiyaz Cheulkar Elite Vaper

    Threads:
    42
    Posts:
    1,807
    Country:
    South Africa
    Joined:
    13/11/17
    Gender:
    Male
    Location:
    Cape town
    Ratings:
    +4,026
    The negative post and the 510 thread should be one piece, and there is no continuity.
    I will open my siren v2 and see if I can find a probable cause.

    Sent from my SM-A730F using Tapatalk
     
  23. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Sub assembly

    Sent from my LYA-L09 using Tapatalk
     
  24. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    Thanks buddy

    Sent from my LYA-L09 using Tapatalk
     
  25. Spongebob

    Excellent Member

    5/5, 1 vote

    Spongebob Experienced Vaper

    Threads:
    44
    Posts:
    485
    Country:
    South Africa
    Joined:
    25/3/16
    Gender:
    Male
    Location:
    Heidelberg gauteng
    Ratings:
    +648
    No such luck

    Sent from my LYA-L09 using Tapatalk