Gen 3 Dual - Coil Readings

Discussion in 'Regulated Devices' started by Sha_Mac, 25/3/19.

Tags:
  1. Sha_Mac

    Not Rated Member

    0/5,

    Sha_Mac New Vaper

    Threads:
    1
    Posts:
    24
    Country:
    South Africa
    Joined:
    12/5/18
    Gender:
    Male
    Location:
    Cape Town
    Ratings:
    +17
    Hi Guys... Hope ya'll are well

    I have a question for users who have / had the Gen 3, did you have any issues with coil readings being way off?
    My coil readings always read way higher than what its supposed to on this mod. Supposed to be 0.18 / 0.19

    I put my tank on a buddy tank this morning, and it reads 0.19 , which is correct, currently on my mod it reads 0.34? Yesterday was reading 0.38 ,and early this morning 0.42

    This is my second Gen 3 mod, and had the same issue with previous mod as well

    Thanks......
     
  2. JurgensSt

    Excellent Member

    5/5, 4 votes

    JurgensSt Vaping Addict Supporting Vendor

    Threads:
    115
    Posts:
    2,590
    Country:
    South Africa
    Joined:
    13/4/18
    Gender:
    Male
    Location:
    West Rand
    Ratings:
    +14,974
    Check for firmware update. Both my Gen 3 Duels are reading fine
     
    • Informative Informative x 1
    • List
  3. Mofat786

    Not Rated Member

    0/5,

    Mofat786 Experienced Vaper

    Threads:
    29
    Posts:
    280
    Country:
    South Africa
    Joined:
    29/3/18
    Gender:
    Male
    Location:
    Cape Town
    Ratings:
    +364
    I have the exact same issue, i have an ijoy genie which always reads a lower ohm, lucky for me though the gen i only keep as a backup, jurgentst u might b onto something as i havent updated the firmware yet, speaking of which how would i go about updating the firmware, all the mods ive had ive always kept the standard installed firmware
     
  4. JurgensSt

    Excellent Member

    5/5, 4 votes

    JurgensSt Vaping Addict Supporting Vendor

    Threads:
    115
    Posts:
    2,590
    Country:
    South Africa
    Joined:
    13/4/18
    Gender:
    Male
    Location:
    West Rand
    Ratings:
    +14,974
  5. Mofat786

    Not Rated Member

    0/5,

    Mofat786 Experienced Vaper

    Threads:
    29
    Posts:
    280
    Country:
    South Africa
    Joined:
    29/3/18
    Gender:
    Male
    Location:
    Cape Town
    Ratings:
    +364
  6. Sha_Mac

    Not Rated Member

    0/5,

    Sha_Mac New Vaper

    Threads:
    1
    Posts:
    24
    Country:
    South Africa
    Joined:
    12/5/18
    Gender:
    Male
    Location:
    Cape Town
    Ratings:
    +17
    thanks guys! will do same
     
  7. Mofat786

    Not Rated Member

    0/5,

    Mofat786 Experienced Vaper

    Threads:
    29
    Posts:
    280
    Country:
    South Africa
    Joined:
    29/3/18
    Gender:
    Male
    Location:
    Cape Town
    Ratings:
    +364
    Updated using the software link provided by JurgenSt and nope didnt work, switched between a drop dead, creed rta and gear rta and the ohms on all 3 were higher on the gen3 than on the ijoy genie, so i took a buddies advice and used a 3rd party updater and installed the arctic fox update and voila, sorted, strange that a 3rd party firmware would fix the issue than the manufacturers firmware. Sha_Mac pls note that the arctic fox firmware is 3rd party so if anything goes wrong your warranty is void. Use at your own risk