Vaporesso GEN - Loose 510 Pin FIX

Discussion in 'Help My Vape Broke!' started by StompieZA, 12/8/19.

Tags:
  1. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Hey guys,

    So after reviewing the Vaporesso GEN and reading Timwis's review and some others, there seems to be an issue with the 510 pin going loose causing the tank to have side to side movement.

    I then decided to open my GEN to see if i can fix the issue only to realize that the 510 pin used does not have a screw on the inside that tightens the 510 pin on the inside. With the tank off you dont get much movement but when a tank is connected and the mod opened up, you can see the connector moving side to side.

    Here is a Video of how bad the movement is after some usage and hope this "Temp" or possible permanent fix helps all the new GEN users out there.

    Video of movement...yeah its bad!



    I then opened the mod by removing the 7 little screws and pulling the black plastic inside out with care not to damage the buttons.

    IMG_20190810_112420.jpg

    I then took some decent super glue and used two (2) drops on each side of the 510 pin while no atty is attached to the mod exactly where the arrows are pointed.

    Use a clear epoxy instead of super glue as per the below thread @Silver posted. It is the safer and more permanent solution.

    IMG_20190810_112416.jpg
    IMG_20190810_112410.jpg
    I left the super glue for 10 mins to ensure its completely dry. Fitted the tank back and there is no movement anymore. The tank still makes 100% connection and no super glue got inside of the 510 pin.

    When putting the device back together again, i found it easiest to hold the mod so that the button holes are facing downward and then dropping the buttons into the holes.

    Then insert the side that holds the board and screens first so that they go in behind the buttons and then pressing the other side which holds the batteries down. You might need to pull away on the body using a small flat head without damaging the plastic or your fingers in order to get the buttons to properly get in behind the button inserts.

    Like mentioned, this is a temp fix and only time will tell if it is a permanent fix and probably depends on the quality of the super glue used.

    I hope that this helps all new GEN users and note that i have sent Vaporesso the above video to make them aware of the issue.

    Cheers.
     
    • Winner Winner x 4
    • Like Like x 2
    • List
    Last edited: 12/8/19
  2. Silver

    Excellent Member

    5/5, 35 votes

    Silver Flavour and throat hit seeker Staff Member Administrator ECIGSSA Donor VIP

    Threads:
    731
    Posts:
    41,879
    Country:
    South Africa
    Joined:
    16/11/13
    Gender:
    Male
    Location:
    Joburg
    Ratings:
    +81,947
    • Like Like x 2
    • Informative Informative x 1
    • List
  3. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Hi Silver,

    Oh yes, i remember this thread. Im sure any strong clue will work as well.

    I understand using super glue on a atty but this is inside the mod inside the 510 where there is also minimal heat so i doubt one will inhale anything but i understand your concern.

    I doubt that super glue is the permanent fix, using pratley epoxy will probably be the best solution agreed.
     
  4. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    OP updated for safety reasons
     
  5. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    I have received feedback from Vaporesso that they have been made aware of the issue and are busy with the quality control and looking at a fix or improving/changing the connection.

    Thanks
     
  6. Hakhan

    Not Rated Member

    0/5,

    Hakhan Dedicated Vaper

    Threads:
    38
    Posts:
    554
    Country:
    South Africa
    Joined:
    29/1/17
    Location:
    Durban
    Ratings:
    +899
    it is such a great mod, i have had mine for about 3 weeks, and hope i don't have to do this.
     
  7. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Hopefully not but luckily its a very simple and easy fix, took me all of 5 min. But yeah it sucks having these type of issues on a mod you recently bought and paid alot for.

    Shout if you ever do need help
     
    • Like Like x 1
    • Winner Winner x 1
    • List
  8. Eisenhorn

    Not Rated Member

    0/5,

    Eisenhorn Experienced Vaper

    Threads:
    7
    Posts:
    185
    Country:
    South Africa
    Joined:
    24/5/17
    Gender:
    Male
    Location:
    Johannesburg
    Ratings:
    +233
    Yay! Typing this while waiting for the epoxy to dry on my 3 month old Gen...
    Hope the "fix" works/lasts
    :worship2:
     
  9. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Awesome and glad that it has helped you. Mine is still 100% after this fix
     
  10. ARYANTO

    Excellent Member

    5/5, 6 votes

    ARYANTO You don't find a happy life , you make it. ECIGSSA Donor

    Threads:
    17
    Posts:
    7,523
    Country:
    South Africa
    Joined:
    7/6/18
    Gender:
    Male
    Location:
    JOHANNESBURG
    Ratings:
    +36,783
    What have you guys done to your Gens ? Have 2 and no issues at all , got one before VC2019 and the other shortly after .
     
  11. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Nothing, Its a global issue on some GEN's
     
    • Like Like x 1
    • Informative Informative x 1
    • List
  12. Deemo

    Not Rated Member

    0/5,

    Deemo Noob Vaper

    Threads:
    0
    Posts:
    19
    Country:
    South Africa
    Joined:
    21/1/19
    Gender:
    Male
    Location:
    East Rand
    Ratings:
    +50
    My Gen has the same issue, thanks StompieZA for the insight really gonna give this a bash:dancer2:
     
  13. t3know

    Not Rated Member

    0/5,

    t3know Noob Vaper

    Threads:
    0
    Posts:
    3
    Country:
    United States
    Joined:
    24/12/19
    Location:
    My Sweet Midwest
    Ratings:
    +3
    Worked fantastically. FWIW mine only acted up after a drop but I suspect based on the number of folks with the issue that it would have happened sooner or later. Used JB Weld Clear
     
    • Like Like x 1
    • Winner Winner x 1
    • List
  14. t3know

    Not Rated Member

    0/5,

    t3know Noob Vaper

    Threads:
    0
    Posts:
    3
    Country:
    United States
    Joined:
    24/12/19
    Location:
    My Sweet Midwest
    Ratings:
    +3
    Also, likely because of the issues.. the mod is going cheaply at 8vape.. $30 for mod only.. which is all I needed with all of my existing tanks
     
  15. ARYANTO

    Excellent Member

    5/5, 6 votes

    ARYANTO You don't find a happy life , you make it. ECIGSSA Donor

    Threads:
    17
    Posts:
    7,523
    Country:
    South Africa
    Joined:
    7/6/18
    Gender:
    Male
    Location:
    JOHANNESBURG
    Ratings:
    +36,783
    @ StompieZA , still no problems on my 2 gens , interesting Q -When did you buy your Gen and what colour [see yours is silver] ? I got mine [red] a week before the Vapecon launch and the other [blue] about 4 weeks later , think maybe it might be a faulty batch / QC issues ?
     
  16. t3know

    Not Rated Member

    0/5,

    t3know Noob Vaper

    Threads:
    0
    Posts:
    3
    Country:
    United States
    Joined:
    24/12/19
    Location:
    My Sweet Midwest
    Ratings:
    +3
    Silver, purchased 2 weeks ago, could easily be batch related. No serial number to be found on this guy
    -Edited for spelling
     
    Last edited: 24/12/19
  17. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    I received mine from vaporesso for review so it would have been a pre-release version. I did discuss the issue with them and they did take a look at it so the newer GEN's would have received a revised 510 connection i assume.
     
    • Informative Informative x 1
    • List
  18. Riaz_sh

    Not Rated Member

    0/5,

    Riaz_sh Experienced Vaper

    Threads:
    9
    Posts:
    100
    Country:
    South Africa
    Joined:
    10/4/19
    Gender:
    Male
    Location:
    Durban
    Ratings:
    +182
    had the loose 510 issue with mine, black in colour
    Clear epoxy worked great!!
     
  19. Smoky Jordan

    Not Rated Member

    0/5,

    Smoky Jordan Vaping... a life changer

    Threads:
    113
    Posts:
    1,000
    Country:
    South Africa
    Joined:
    22/4/15
    Gender:
    Male
    Location:
    Edenglen
    Ratings:
    +877
    Anyone had their fire button pushed in flush with the mod? Still fires but no clicking sound when pressed. Can this be fixed? Would it be a warranty claim?
     
  20. Resistance

    Excellent Member

    5/5, 8 votes

    Resistance Vaping Master

    Threads:
    55
    Posts:
    8,203
    Country:
    South Africa
    Joined:
    15/12/17
    Location:
    Cape
    Ratings:
    +28,038
    When that happens you have two scenarios.either the switch will still hold up or it will eventually give in.
    I don't have a GEN but if it's a tactile switch which I think it is because most mods use them.
    The switch has a metallic disc under the rubber button it's convex/concave depending how you look at it. This makes it springy and failure normally amounts to this disc to become kinked or flat.
    This can be fixed by replacement of the tactile switch.
    As for warranty,only the vendor can answer that question.
     
  21. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    Perhaps follow the above steps to open the mod and look at the button and switch, perhaps its just dirt or perhaps misaligned otherwise if it is the switch there are a couple of vape stores that should be able to replace the switch that do mod repairs.
     
  22. Smoky Jordan

    Not Rated Member

    0/5,

    Smoky Jordan Vaping... a life changer

    Threads:
    113
    Posts:
    1,000
    Country:
    South Africa
    Joined:
    22/4/15
    Gender:
    Male
    Location:
    Edenglen
    Ratings:
    +877
    Thank you so much for the info really appreciate it
     
  23. Smoky Jordan

    Not Rated Member

    0/5,

    Smoky Jordan Vaping... a life changer

    Threads:
    113
    Posts:
    1,000
    Country:
    South Africa
    Joined:
    22/4/15
    Gender:
    Male
    Location:
    Edenglen
    Ratings:
    +877
    Could you advise which vape stores do repairs @StompieZA
     
  24. StompieZA

    Excellent Member

    5/5, 5 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    111
    Posts:
    2,127
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +5,931
    a quick google search shows that Atomix Vapes in kempton park and The Vape Mafia also in kempton does repairs.
     
    • Thanks Thanks x 1
    • Can relate Can relate x 1
    • List
  25. Smoky Jordan

    Not Rated Member

    0/5,

    Smoky Jordan Vaping... a life changer

    Threads:
    113
    Posts:
    1,000
    Country:
    South Africa
    Joined:
    22/4/15
    Gender:
    Male
    Location:
    Edenglen
    Ratings:
    +877
    Awesome thanks, will have to pop past there soon