Vaporesso GEN - Loose 510 Pin FIX

Discussion in 'Help My Vape Broke!' started by StompieZA, 12/8/19 at 07:54.

Tags:
  1. StompieZA

    Excellent Member

    5/5, 2 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    79
    Posts:
    1,542
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +4,188
    Hey guys,

    So after reviewing the Vaporesso GEN and reading Timwis's review and some others, there seems to be an issue with the 510 pin going loose causing the tank to have side to side movement.

    I then decided to open my GEN to see if i can fix the issue only to realize that the 510 pin used does not have a screw on the inside that tightens the 510 pin on the inside. With the tank off you dont get much movement but when a tank is connected and the mod opened up, you can see the connector moving side to side.

    Here is a Video of how bad the movement is after some usage and hope this "Temp" or possible permanent fix helps all the new GEN users out there.

    Video of movement...yeah its bad!



    I then opened the mod by removing the 7 little screws and pulling the black plastic inside out with care not to damage the buttons.

    IMG_20190810_112420.jpg

    I then took some decent super glue and used two (2) drops on each side of the 510 pin while no atty is attached to the mod exactly where the arrows are pointed.

    Use a clear epoxy instead of super glue as per the below thread @Silver posted. It is the safer and more permanent solution.

    IMG_20190810_112416.jpg
    IMG_20190810_112410.jpg
    I left the super glue for 10 mins to ensure its completely dry. Fitted the tank back and there is no movement anymore. The tank still makes 100% connection and no super glue got inside of the 510 pin.

    When putting the device back together again, i found it easiest to hold the mod so that the button holes are facing downward and then dropping the buttons into the holes.

    Then insert the side that holds the board and screens first so that they go in behind the buttons and then pressing the other side which holds the batteries down. You might need to pull away on the body using a small flat head without damaging the plastic or your fingers in order to get the buttons to properly get in behind the button inserts.

    Like mentioned, this is a temp fix and only time will tell if it is a permanent fix and probably depends on the quality of the super glue used.

    I hope that this helps all new GEN users and note that i have sent Vaporesso the above video to make them aware of the issue.

    Cheers.
     
    Last edited: 12/8/19 at 08:03
  2. Silver

    Excellent Member

    5/5, 35 votes

    Silver Flavour and throat hit seeker Staff Member Administrator ECIGSSA Donor VIP

    Threads:
    695
    Posts:
    40,194
    Country:
    South Africa
    Joined:
    16/11/13
    Gender:
    Male
    Location:
    Joburg
    Ratings:
    +74,434
    • Like Like x 1
    • Informative Informative x 1
    • List
  3. StompieZA

    Excellent Member

    5/5, 2 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    79
    Posts:
    1,542
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +4,188
    Hi Silver,

    Oh yes, i remember this thread. Im sure any strong clue will work as well.

    I understand using super glue on a atty but this is inside the mod inside the 510 where there is also minimal heat so i doubt one will inhale anything but i understand your concern.

    I doubt that super glue is the permanent fix, using pratley epoxy will probably be the best solution agreed.
     
  4. StompieZA

    Excellent Member

    5/5, 2 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    79
    Posts:
    1,542
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +4,188
    OP updated for safety reasons
     
  5. StompieZA

    Excellent Member

    5/5, 2 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    79
    Posts:
    1,542
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +4,188
    I have received feedback from Vaporesso that they have been made aware of the issue and are busy with the quality control and looking at a fix or improving/changing the connection.

    Thanks
     
  6. Hakhan

    Not Rated Member

    0/5,

    Hakhan Experienced Vaper

    Threads:
    27
    Posts:
    455
    Country:
    South Africa
    Joined:
    29/1/17
    Location:
    Durban
    Ratings:
    +721
    it is such a great mod, i have had mine for about 3 weeks, and hope i don't have to do this.
     
  7. StompieZA

    Excellent Member

    5/5, 2 votes

    StompieZA Reviewer, DIY Lover & Flavor Chaser

    Threads:
    79
    Posts:
    1,542
    Country:
    South Africa
    Joined:
    7/6/16
    Gender:
    Male
    Location:
    Kempton park
    Ratings:
    +4,188
    Hopefully not but luckily its a very simple and easy fix, took me all of 5 min. But yeah it sucks having these type of issues on a mod you recently bought and paid alot for.

    Shout if you ever do need help